Halo Connection Issues

Minor incident Skydrop Cloud
2018-05-13 20:53 MDT · 11 minutes

Updates

Resolved

Return to normal operations

May 13, 2018 · 21:04 MDT
Investigating

Investigating connection issues affecting a very small percentage of Halo controllers.

May 13, 2018 · 21:02 MDT

← Back